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Abstract

The teaching material includes exercises about retrieving phytoplankton surface bloom
information based on remotely sensed Chlorophyll a (Chl a) in large shallow lake L. Peipsi
(Estonia/Russia), using the ESTHub satellite data processing portal by the Estonian Land
Board and SeNtinel Application Program (SNAP). The main aim is image processing in
ESTHUB and in SNAP (9.0.0), applying masks to calculate the bloom area, and using Level 3
processing possibilities for spatio-temporal analyses. A short introduction to the
cyanobacterial blooms, major bloom formers in L. Peipsi and common problems due to the

surface blooms is given.
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Introduction to the cyanobacterial blooms

Phytoplankton presence in lakes is a natural phenomenon, and phytoplankton forms the basis of a
food chain in waterbodies. Lakes and reservoirs are often used as drinking water resources and are
relevant for recreation, tourism and irrigation purposes. Problems arise when excess nutrients and
warm weather support massive development of cyanobacteria, and this may hinder and prevent
normal activities and water body’s usage, e.g. when surface scum is reaching to the shoreline, and
the presence of toxic blooms may lead to severe drinking water crisis (Backer, 2002, Steffen et al.,
2017). A mass of cyanobacteria produces oxygen in the daytime and consumes it during night-time

and decay, causing stress for fishes and subsequent fish kills.

The increase of blooms is a particular concern in inland waters (Brooks et al., 2017, Malthus et al.,
2019) as the problems with clean freshwater scarcity tend to increase across the globe (WHO, 2022).
In the frames of changing climate and rising temperatures, cyanobacterial blooms are increasing in
frequency, magnitude and duration on a global scale (Taranu et al., 2015, Huisman et al., 2018, Paerl|
et al., 2020).

Bloom definition

It is not always easy to distinguish what is meant by the bloom. Generally, a bloom is:

e arapid and remarkable increase in the concentration of phytoplankton

o development of a level of phytoplankton biomass that is uncharacteristically high for a given
water body

e discoloration of waters

e visible scum at the water surface

e an elevated biomass that is above the biomass in the reference state of a given lake, which
interferes with the ecosystem services and functioning of this lake.

Ibelings et al. (2016) noted that important is not the presence of cyanobacteria in the community,
but the level of their amount for defining a bloom. According to WHO (2021), in the case of
cyanobacterial dominance, Chl a concentration > 12 pg/L, is regarded as harmful with a suggestion
to raise an alert. For L. Peipsi, this value is too low; thus, for the bloom characterization, a median
value for each separate lake part was calculated, and a median value exceeded by a 5 % threshold
was chosen to mark the bloom initiation (Table 1). This requires the presence of the long-term

dataset, and in case of L. Peipsi, the Chl a measurements started in 1989.

Table 1. Bloom thresholds for various lake parts of L. Peipsi.

Lake part | Chl a long-term median | + 5%

Peipsi s.s. 17.1 pg/L 18.0 ng/L
Lammijirv 34.0 ug/L 35.7 ng/L
L. Pihkva 44.4 ng/L 46.6 pg/L




Common bloom formers

The main planktonic widely-distributed toxin-producing bloom-formers include N> fixing
genera Dolichospermum (former Anabaena), Aphanizomenon, Cylindrospermopsis,
Nodularia, the non-N; fixing genera Microcystis and Planktothrix (Paerl & Paul, 2012).
Cyanobacteria are capable of very fast replication and rapid vertical movement within the
water column, resulting in the formation of dense surface scums (Paerl & Huisman, 2009,
Vaiditte et al., 2021). Most bloom-forming cyanobacteria contain gas vesicles (aerotopes)
which provide buoyancy and allow to form dense surface blooms during quiet weather
(Wynne et al., 2013), which, for their patchy nature, is hard to study in the frames of regular
monitoring activities. Remote sensing allows to quantify the blooms, find the initiation date,
and track the movement of the bloom.

Lake Peipsi —the study area

Lake Peipsiis a large transboundary waterbody (surface area
3555 km?) shared between Estonia (44%) and Russia (56%). It
consists of three parts — northern and largest Peipsi sensu
stricto (s.s.), southern L. Pihkva and their connection
Lammijarv (Figure 1, Table 2). L. Peipsi has 240 inflows; the
largest is the Velikaja River (Peipsi, 2008), and the outflow is
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Common cyanobacteria, present in L. Peipsi, are visible in Figure 2. Cyanobacterial blooms are a

common feature in L. Peipsi, dating back to the first written notes, but the dominant bloom-formers
have been changed over the years. At first, Aphanizomenon was mentioned, then colonial
cyanobacterium Gloeotrichia echinulata (a species with mesotrophic preferences (Laugaste et al.,
2013)) caused heavy blooms, and during recent years Dolichospermum lemmermannii and species of
Microcystis are more common, causing blue-green water in the shoreline
(https://www.terviseamet.ee/et/uudised/peipsi-jarves-vohab-sinivetikas).

Part of the cyanobacterial population is capable of fixing their own nitrogen via heterocysts,
depending only on phosphorous and adding extra nitrogen to the water.



Table 2. The basic information about L. Peipsi.

Surface area (km?) 2,611

Volume (km?3) 21.79 0.6 2.68
Mean depth (m) 8.3 2.5 3.8
Max depth (m) 12.9 16.3 5.3
Trophic state Mesotrophic Eutrophic Eutrophic

Figure 2. Common cyanobacteria in Lake Peipsi A- Gloeotrichia echinulata, B- Dolichospermum

lemmermannii, C- Microcystis wesembergii, D- Microcystis aeruginosa, E- Aphanizomenon flos-
aquae, F-Dolichospermum sp. Photos by K. Maileht.

Exercises in this tutorial
1) Calculation of Chl a from a single satellite image, using ESTHub L2 processing,
followed by creation of bloom mask with Mask Manager to retrieve the bloom area
in SNAP software.
2) Use batch processing in SNAP to retrieve bloom information from multiple images.
3) Use Level 3 binning in ESTHub for spatio-temporal analyses (an average over the
selected time period).

Establishment of the ESTHub account (national ID number is needed) — necessary pre-task
before the course.



More information: https://geoportaal.maaamet.ee/eng/Spatial-Data/National-Satellite-
Data-Centre-ESTHub-p654.html

This exercise includes using the ESTHub processing platform (Login to ESTHub Processing
Platform: https://ehcalvalus.maaamet.ee/calest/calvalus.jsp) and Sentinel Application
Platform (SNAP).

ESTHub is a processing platform for Earth Observation images, which is hosted by Estonian
Land Board and covers Estonian territory and its surroundings. The Sentinel Application
Platform (SNAP) 9.0.0. is a program for Earth Observation processing and analysis,
downloadable from https://eo4dsociety.esa.int/resources/snap/.

1. Retrieval of the bloom area from 1 selected image

The first exercise is about the usage of Level 1 data and the retrieval of Chlorophyll a
concentration via the Maximal Chlorophyll Index and regionally tuned specific coefficients
over L. Peipsi, to retrieve lake part specific surface bloom area.

In ESTHub, select L2 Processing from the left pane and Sentinel 3 OLCI EFR Level 1 from the
Input File Set.

Processing Service

Input File Set

Py Show predefined file sets
Match-up Analysis (J Show my outputs ' and of other users
T T 900
: 4| Name Sentinel 3 OLCI EFR Level 1
Regional Statistics Sentinel-1 GRD o
Sentinel-1 OCN Type: §3_OLCI_L1B_EFR
L3 Processing Sentinel 3 OLCI EFR Level 1 Start Date:  2016-04-26
Sentinel 3 OLCI LFR End Date 2024-12-31
Sentinel 3 OLCI WFR Region name: Baltic
Sentinel 3 SLSTR RBT Level 1 Geo Inventory: Yes

Sentinel 3 SLSTR LST

Oantinal 4 OL OTO IOT

Show Help

Temporal filter: type the date: 12.07.2023. Spatial filter can be either global or more
specific. Region can be specified: from Add and manage user regions, zoom in to area of
interest, draw a new polygon and save it as a new user region. Return to L2 Processing and
under Spatial filter, select the user defined area:




Temporal Filter Spatial Filter

O No filter O No filter (global) @ By region
ratymHa Ki
OBy date range » [ EstHUB ' o - 4";
Start . » Map Satellite La B
date: 2017-06-01 (J training R -
ate: ’ ——
Velik:
End — 7017.06-30 Y @ user Luga Sl N vaorad
date: " ; . Estonia o ,----.....:HBenuKuﬁ
. [ fegion_1—— | =) ¢ oBropoa
@ By date list o Viiandi If%rtu 9
2023-07-12 Staraya Russ
Crapasg Pycc
A Valmiera
(e}
1 days .
Show Help G? leﬁg B Map data ©2024 Goc;gle Terms

Add and manage user regions

In Level-2 Processor, select Maximum chlorophyll index (MCl):

Level-2 Processor Level-2 Parameters

Processors of other users K4 Highest version
Matching input type

My processors
System processors

<none>
Case 2R/CoastColour Processor for OLCI with Idepix v1.91
Case 2R/CoastColour Processor for OLCI with Idepix v1.91
Case 2R/CoastColour Processor for 3 OLCI v1.91

Case 2R/CoastColour Processor for $3 OLCI v1.91

Cloud screening with SNAP Idepix for OLCI v7.0.0

ICOR atmospheric correction processor for S3 OLCI v3.0
Maximum chlorophyll index (MCI) from EFR v7.0.0
Polymer L2 v4.16.1.forscientificuse

SNAP generic BandMaths v1.1

SNAP generic Subset v1.2

Input Types: S3_OLCI_L1B_EFR
Bundle: s3tbx-flhmci v7.0.0
Owner: System

P Processor description:

Show Help

<parameters=
<lowerBaselineBandName=0a12_radiance</lowerBaselineBandName>
<upperBaselineBandName=0a10_radiance</upperBaselineBandName=
<signalBandName=Qa11_radiance</signalBandName=>
<maskExpression=(lquality_flags.land or quality_flags.fresh_inland_water) and !

quality_flags.invalid</maskExpression=
<slope>true</siope=
<slopeBandName>MCI_slope</slopeBandName=>
<lineHeightBandName>MCl</lineHeightBandName=>
=cloudCorrectionFactor=1.005</cloudCorrectionFactor>
<invalidFihMciValue>NaN</invalidFihMciValue>

</parameters>

)

Edit Parameters

| Choose File | No file chosen

Output Parameters Allow failing products, say the production name, ask the netCDF4
format and allow some extent of failing (20%). Then click Order Production.

Output Parameters

Production name: 1207

|

the production to identify it later on. If le

Provide a nam

O Process to Cluster-Internal-Format
® User product

Product file format: | NetCDF4 bud

Note that t ailable product file formats

Perform staging step after successful production

Percentage of allowed failing products

Request queue

If you are entitled fo ral

the queue for the project you are processing for.

Show Help

pty, a name will be generated from the g

Check Request Save Request Order Production

Under Productions (on the left pane in ESTHub) is a tab showing the progress in processing
(and if there are any errors) and a list of processed files, which can be downloaded after the
processing is complete.



Processing Service

¥ Production User Processing Stat

L2 Processing
Match-up Analysis
Regional Statistics

L3 Processing

Regions

Requests

File Edit View Analysis Layer Ve

;ﬁ, Open Product...

|

Recpen Product
Product Library

idiZ;;v;r;g‘é;;e‘ kersti.kangro COMPLETED
ZbZé_a\}é}age_;) kersti.kangro COMPLETED
50243_};4»77— ) kersti kangro COMPLETED
:2;20?0‘66;24[;275;:3&jlé:j:m kersti kangro COMPLETED
i1 kerti angro CouPLETED
34_03{'_}&;4_;;; 8_L2Pius_7adcbO2echfebb kerst kangro ——
igd%gre«gh|o__>-: I kersti.kangro COMPLETED

Click on Download, download the S3A file with the ending _1980.nc.
The analyses continue in SNAP. Open SNAP and open the
downloaded file (File -> Open Product -> L2_of _S3A....nc)

Close Product
Close All Products
Close Other Products

Save Product
Save Product As...

Session
Projects
Import
Export

Exit

File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help

agenElLsse g roassINyRoOR 2

[ E

Product Explorer X | Pixel Info

- (3 Metadata

i1- (23 Flag Codings
i1- (23 Vector Data
+- (31 Tie-Point Grids

=3 Bands

y O e OO e OO

- (23 Masks

EM=W[1]L2 of S3A_OL_1 EFR 202307121083253_20230712T083553_20230713T091837_0179_101_064_1980_PS1 O_NT_003

Select MCI band (Under Bands, click on the +, double-click on MCI (708.8 nm)) and open the

image window.



s onikace XE ARG N YROOR = |
roduct Explorer X | Pixelinfo | —|[@ma x

& [1112.0f 53 OL_1 EFR___ 202307127083253_20230712T083553_20230713T091837_0179_101 064 _19;
@@ Metadata
@ (3 Flag Codings
5@ Vector Data
4@ Tie-Point Grids
=-&3 Bands
B mc1 (708.8 nm)
B ™cI_siope
@ qualty_flags
@
@ lon
(23 Masks

|v

ayer Editor Quicklooks Navigation - [1] ... | Colour Mani... X | Uncertainty Vis...

Editor: @ Basic () Siders () Table:

>

Scheme

&

- none v

Palette
unnamed

[ma

[ Load exact values Reverse

If the image area is too large, you can create a subset with Peipsi: Right-click on the screen
and choose “Spatial subset from View” and narrow the window with a mouse down to the
L. Peipsi, click OK - this reduces the file size and speeds the processing.

-

E Specify Product Subset
t Band Subset Tie-Point Grid Subset Metadata Subset
: 4 .'.‘:\ ~
|:| 2 o oo Pixel Coordinates Geo Coordinates

4 ; Scene start X: 1472 3

Scene start Y: 1056 -5

Scene end X: 2336 =

Scene end Y: 21443

4 Scene step X: 15

3 Scene step ¥: 15
Subset scene width: 865.0
1 Subset scene height: 1089.0
Source scene width: 4865
Source scene height: 4020

[ Fix full width
Use Preview
[ Fix full height
W
Estimated, raw storage size: 69.6M
Cancel Help

T T
A subset is opened as a new file below the original file. Go to the subset file

(subset 0 of ...) and open the MCl image window.

Calculate Chl a concentration from MCI (Alikas et al. 2010) using Raster ->Band Maths:




File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help

|;§ % % % /J(% G% Band Maths... ~i 1
Product Explorer X ‘ Pixel Info ‘ =
- [1L2.of S3A OL_1 EFR__ 2023 o 7 013
(23 Metadata i
E*G Floy Codings Geo-Coding Displacement Bands...
E}Q Vector Data Subset...
- (@3 Tie-Point Grids DEM Tools »
EM_ﬂ Bands e 3
----- B mcI(708.75 nm) Masks 5
o[ MCI_slope ]
_____ ﬁ iclvey: Ml Data Conversion ¥
_____ B it Image Analysis >
[ lon Classification >
G- (03 Masks Segmentation b
&8 [2subset 0_of 12 of 534 OL 1] Export y BOTILZ
@E — Bands extractor

-2 Flag Codings

Raster -> Band Maths -> In the opened dialogue box, give a Name to the band, e.g., Chl a. Edit
Expression -> in Expression window -> enter the formula. Type in the formula: MCI*10.9+15.3
Click OK.

B Band Maths *

Target product:
[2] subset_0_of L2 of 53A_OL_1 FFR___ 20230712T083253_20230712T083553_20230713T091837_0179_101_084_1980_PS1_O_NT_003 “
Name: Chla
Description:
Unit:
Spectral wavelength: 0.0
Virtual (save expression only, don't store data)
Replace NaM and infinity results by NaN
[[] Generate associated uncertainty band

Band maths expression:
MCI*10.9+15.3

Load... Save... Edit Expression...

Cancel Help

co

An image of Chl a will appear (if not, click on Chl a band (last in the list under Bands) and
Open Image Window).).

Then use the Colour Manipulation window (View-> Tool Windows) to assigh colours to Chl a
product. Under Palette, you can select “oceancolour_standard.cpd”. The colouring is

10



continuous. Under , More options“, you can also switch to , discrete colours”. The Range

can be defined either from data or from palette, and the result changes accordingly.

avigation - [8] Chl a [ Colour Manipulation - [8] Chla X | Uncertainty Visualisation ’ World View

Editor: (@) Basic () Sliders () Table

Scheme

--none - i

Palette
derived from oceancolor_standard.cpd

I e 9 B

Load exact values Reverse

Range
Min: 1.0952443 Max: 110.0

- - e - -

Also, a slider or table view can be used, where values and colours can be changed by
double-clicking on them.

FPDdE : v |

Name: Chla
Unit: null

Min: -75.05
Max: 100.524
Rough statistics!

0's6 k&
D'so1t

The modified colour palette can be saved into a new cpd file =, Later, this new colo

B

palette can be chosen from the “Import colour palette”

w
i

0'SL
0'os
0's8
0'Ee

p'ott

ur

and applied to another image.
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Colour legend can be exported as a File or as an Image.
Click on the image and select Export Colour Legend as
Image. Under Properties, colour legend can be
modified (header text, orientation, etc.)

Look at the retrieved Chl a image — where are lower
Chl a values? Is Chl a equally distributed in L. Peipsi
s.s.? You can use Colour Manipulation tool and adjust
the gradient by moving the arrows under the Sliders
to focus on different parts in Lake Peipsi.

For the bloom classification:

Import the shapefiles for three parts of L. Peipsi (the file name in the Product Explorer
window needs to be selected): Vector-> Import -> ESRI shapefile (the shapefile folder has to
be unzipped) -> select all three shapefiles -> specify the target CRS at WGS84

E [2] subset_0_of_L2_of S3A_OL_1_EFR___20230712T083253_20230712T083553_20230713T091837_0179_101_064_1980_PS1_O_NT_003 - [not saved] - SNAP
File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help

& [;:}‘] % E% % \E‘é New Vector Data Container ):_'._ GE’:_ \+ D [:4]- <'€7 Q E% g by Dﬂ g E

Product Explorer X | Pixel Info Geomety fromWKT -] ..

5 [ McI (708.75 nm) A
Bl MCL_slope Import > SeaDAS 6.x Track
g lc;utahty_ﬂags Export > Vector from CSV
[ lon MERMAID Extraction File

- (3] Masks ESRI Shapefile
5= 2] subset 0_of L2 of 53A_OL_1_EFR___202307127083253_2023071 [FG RN -nt Mg S
{ [E-[33 Metadata

Coordinate Reference System will be asked, the default selection may stay.

B¥ \mport SHAPEFILE Data P

The vector data are not associated with a coordinate reference system (CRS).
Please specify a CRS so that coordinates can be interpreted correcthy.

Coordinate Reference System (CRS)

WGS84(DD)

() Custom CRS

Geodetic datum: |World Geodetic System 1984
Projection: Geographic LatfLon (WGS 84)
Projection Parameters...

() Predefined CRS Select...

Cancel Help
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Shapefiles will appear as masks in the Mask Manager (View-> Tool Windows->Mask
Manager). Its Type is Geometry. You can change the name, colour and transparency of the
layer. Select a shapefile to make it visible on the image.

SYBQ@ R  MEEE

— oM @moia Mmoo v o vesn %[ E O B 1 e _sova | I 91 1acE e x&

g g | st @ | e

% Unceraing Visuslisagon  Word View.

Ev
icl

!

n g

£ type here to search

For bloom characterization, a new bloom mask according to Chl a thresholds (see Table 1 in
the Introduction section) needs to be calculated. First, let’s calculate the mask for Peipsi s.s.:

on the Mask Manager, click on ) to create an expression. Tick on Show masks and Show

bands. Select Peipsi_suurjarv mask, type “and” and select Chla band and add the threshold
based on the value from Table 1 for bloom definition.

¥ New Logical Band Maths Expression X

Data sources: Expression:

quality flags_saturated Oal3 ~ @ and @ Peipsi_suurjarv and Chla>=18§
quality flags saturated 0Ca20l

= = = @ or @
quality flags_saturated OaZl

. . - not
Peipsi_suurjarv B

Lammi_jarv (@)

Pihkva jarv Constants. .. b
new _mask 3¢€
= — Operators. .. e

ss_mask v
Show bands

Show masks

[[] Show tie-point grids

[[] show single flags % ::ﬁ: @ Ok na soe
Cancel Help

Functions. .. =~

Give name to new mask. Repeat these steps for Lammijarv and Lake Pihkva with respective
thresholds (Table 1). Compile 3 masked areas: select the new masks for three parts of the

lake and then click on G to create a union between the masks.
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Masks can be exported

~ and later imported

clicking on it. Export the combined bloom masks.

, for later usage. Select the mask by

According to the masked area, find out how large are the bloom areas in all lake parts?

B snap

File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help

FLEL Y Y

Product Explorer X | Pixel Info I
=& [1]L2_of S3A_OL_1 EFR___ 2023
- (33 Metadata

#-[Z] Flag Codings

- (C3 Vector Data

& (Z3 Tie-Point Grids

—-&3 Bands

----- [ wc1 (708.75 nm)

----- @ MCI_slope

...... [@ quality_flags

G- (Z3 Masks
=& [2] subset_0_of 12_of S3A_OL_1_|

G- (23 Metadata
- (23 Flag Codings

Band Maths...

DEM Tools
Geometric
Masks

Data Conversion
Image Analysis
Classification
Segmentation
Export

Bands extractor

»
»

TNvEYe R

[

7_0179_101_064_1980_PS1_O_NT_003

Land/Sea Mask

Terrain Mask

Mask Area...

Fractional Land/Water Mask
LandCover Mask

s bersorem e r—sree—rwe—ol NT_003

This can be done via Raster -> Masks -> Mask area. Select the specific mask from the list

and find the surface area in kmZ.

Mask size for the Peipsi_suurjarv is 2881.3 km?.

Mask area:
Mean pixel area:
—| Minimum pixel area:

| Maximum pixel area:

Mean earth radius:

-t

ﬁ Compute Mask Area - [2] Peips... X

Mumber of Mask pixels: 33523

2881.345 | km~2
0.086 | km~2
0.015 | km~2
0.123 | km~2

6378.137 | km

o]

Help

Mask area:
Mean pixel area:
Minimum pixel area:

Maximum pixel area:

Mean earth radius:

ﬁ Compute Mask Area - [2] Peips... X

Mumber of Mask pixels:

2426.251 | km~2

6378.137 | km

El

The surface area for bloom is (geometry mask
Peipsi_suurjarv and Chl a > 18 pg/L) 2426 km?.

28259

0.086 | km~2
0.016 | km~2
0.122 | km~2

How large is the bloom area in a) Limmijarv; b) Pihkva, c) over the whole lake?
Close the product and save the file.
Optional exercise: do the L2 Processing in ESTHub for the Gulf of Finland area of the same
day, calculate Chl a from MCI, apply the colour scheme and look at the visible part of the

Gulf of Finland. Can you see the bloom?
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2. Using Graph Builder and Batch Processing Tool in SNAP

This exercise teaches to process several images simultaneously in SNAP, using graph builder
and batch processing. Additionally, a possibility to create an average image with a Level 3
Binning opportunity is shown.

For that, use ESTHub L2 Processing, Sentinel 3 OLCI EFR images with MCl according to the
instructions from the first exercise for 3 days (e.g. 15™, 16 and 22" September 2023).
Select User -region_1, containing L. Peipsi. Download one S3A image (with the ending code
_1980.nc) per date.

In SNAP many images may be processed simultaneously using Graph Builder * ~ and Batch

oo
oo-C

Processing Tool % Inthe Graph Builder, a sequence of activities can be listed.

Open SNAP and create a Graph Builder scheme for further processing. Right click on the
screen and select the processing tool. At first, add the Subset selection (Add-> Raster-
>Subset) to focus more precisely on L. Peipsi.

B Graph Builder X
File Graphs

Add > Input-Output >
Connect Graph Optical
Radar

>
>
Raster >
>
>

Change Detection

Tools Classification

PPBpbDl

Vector Data Conversion
DEM Tools

Geometric

PbDI

Image Analysis
Masks
BandMaths

vV vV vV v v v v

o
< % BandMerge >
“re Fli
Read Write ot ip
Source Product W Image-Filter
Name: 8 S
w TemporalPercentile 2
Data Format: v

Then add BandMath for the calculation of Chl a (Add-> Raster-> Band Maths). Then right-
click and select Connect graph. Connecting arrows will appear. Save the graph, e.g.
MyGraph.xml

15



E Graph Builder
m Graphs
Load Graph A
[ Save Graph
View Graph XML

<

-~

Read Write Subset BandMaths
Source Product
Name:

Data Format:

Advanced options

Product Explorer: Open three L2 products from September in SNAP.

B snap

File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help

=L H Y $"Y -4 - RN e vy B X

Product Explorer X l Pixel Info {
& & [1]L2_of S3A_OL_1 EFR 20230915T084749_20230915T085049_20230916T093246_0179_103_221_1980_PS1 O,

& [2]L2_of S3A_OL_1_EFR___ 20230916T082138_20230916T082438_20230917T085911_0179_103_235_1980_PS1_O,
& [3]L2_of S3A_OL_1_EFR 20230922T090631_20230922T090931_20230923T094800_0179_103_321_1980_PS1 O,

Select Batch processing. - Use
saved graph file from Load Graph.

to load all three files. Load the previously
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B Batch Processing X
File Graphs

{1/O Parameters :

File Name Type Acquisition Track Orbit
L2_of S3A_OL_1_EFR___ 2...|org.esa.s3tbx....
L2 of S3A_OL_1_EFR___ 2...|org.esa.s3tbx....
L2_of S3A_OL_1_EFR___ 2...|org.esa.s3tbx....

dul 4

e € B I

2

¥ I

3 Products

Run remote Load Graph Run Close Help

The titles occur besides I/O Parameters, which can be modified. Under Subset, select MCl as
a source band and select Geographic Coordinates.

1/O Parameters Subset BandMaths Write

Sarcesonts (L

MCI_slope
quality_flags
lat

lon

Copy Metadata

(O Pixel Coordinates (@) Geographic Coordinates

Reference band: MCI

(% |

- ht::‘ I
Use "~ to specify the target area with a mouse inside the red bounding box and click
Update. A new polygon will be selected.

() Pixel Coordinates (@) Geographic Coordinates

teference band: MCI
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A new polygon is specified under Subset with coordinates according to the drawn yellow
polygon. As this might take a while, fill in the Band Math section meantime.

Under Band Math, select Target Band: Chl a and add an expression for Chl a calculation.

I/O Parameters Subset BandMaths rite
Target Band: Chla
Target Band Type: |float32
Band Unit:
No-Data Value: 0.0
Expression: MCI*10.9+15.3

Edit Expression...

Under the WRITE section, specify the folder where products will be generated, and save as a
NETCDF4-CF file.

File Graphs

1/O Parameters Subset BandMaths Write
Target Product

Name:

Subset_L2_of S3A_OL_1_EFR____20230915T084749_20230915T085049_20230916T093246_0179_103_221_1980_PS1_O_NT_003_BandMath

Save as: }
Directory:
C:\Users\kiti\L3_subsetist

Then hit RUN.
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E Batch Processing : myGraph3.xml X

File Graphs
Processing 2 of 3L2_of_S3A_OL_1_EFR 20230916T082138_20230916T082438_20230917T085911_0179_103_235_1980_PS1_O_NT_003.nc

1/O Parameters Subset BandMaths Write
Target Product

Name:
Subset_L2_of_S3A_OL_1_EFR 20230916T082138_20230916T082438_20230917T085911_0179_103_235_1980_PS1_O_NT_003_BandMath

Save as: NetCDF4-CF v
Directory:
C:\Users\kiti\L3_subsetist

Computing raster data...

67% Cancel
Estimated 2 seconds remaining Run remote Load Graph Help
Three new files will be created.
Product Explorer X l Pixel Info —
+ E [1] L2_of S3A_OL_1_EFR 20230915T084749_20230915T085049_20230916T093246_0179_103_221_1980_PS1_0]
+ & [2]1 L2_of S3A_OL_1_EFR 20230916T082138_20230916T082438_20230917T085911_0179_103_235_1980_PS1_O|
+ E [3] L2_of S3A_OL_1_EFR 20230922T090631_20230922T090931_20230923T094800_0179_103_321_1980_PS1_O]
+ & [4] Subset_L2_of S3A_OL_1_EFR 20230915T084749_20230915T085049_20230916T093246_0179_103_221_1980|
[+ g [5] Subset_L2_of S3A_OL_1_EFR 20230916T082138_20230916T082438_20230917T085911_0179_103_235_1980,
+ a [6] Subset_L2_of S3A_OL_1_EFR 20230922T090631_20230922T090931_20230923T094800_0179_103_321_1980|

Product explorer Open Chla band in one of the subsets.

B (4] Chla - Subset 12 of S3A_ OL_1_EFR__20230915T084749_20230915T085049_20230916T093246_0179_103_221_1980_PS1_O_NT_003_BandMath - C:\Users\kiti\L3_subsetist\Subset L2 of S3A OL 1 EFR__20.. — o

Gile Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help Q-
1 (74} Ht ) GCF D GCP Te
6*‘&»;%-‘;;&@%1“C§R@Qq +\+DEQ§®@\~;\

Product Explorer X | Pixel Info ~ |[@ M che x
¥ W (112 0f S3A_OL_1 EFR___20230915T084749_20230915T085049_20230916T093246_0179_103_221_1980_PS1 A
o W [ L2 0of S3A_OL_1 EFR___20230916T082138_20230916T082438_20230917T085911_0179_103_235_1980_PS1
4@ [3]L2.0f S3a_OL_1 EFR___20230922T090631_20230922T090931_20230923T094800_0179_103_321_1980_PS1
= @ (4] Subset L2 of S3A OL_1 EFR___20230915T084749_20230915T085049_20230916T093246_0179_103_221_1¢
4 O Metadata
4 @ vector Data

B P_lattude
@ ™ _ongtude
@ oas

-

<

Navigation - [4] Chla X Colour Manipulation - [4] Chia Uncertainty Visualisation World View

cEArsMP| |
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Use L3 binning (Raster->Geometric -> Level 3 Binning) to find an average Chl a of three
September images.

Raster Optical Radar Tools Window Help

w
g Band Maths... {; N ;\7 El Q‘) @ t& =

Geo-Ceding Displacement Bands...
Subset...

DEM Tools

Geometric

Masks

Data Conversion

Level-3 Binning
Mesasicking

Reprojection
Image Analysis Resampling
Classification GeFolki Co-registration

B " I VI P I R

F—— Multi-size Mosaic
rt

g Collocation

Bands extractor

A new window opens. Click on ™ , Add product(s) and select three subset products -> OK.

Under Configuration tab, click on T > under Edit Aggregator select Chla as a Source band

name and AVG as editing aggregator. Click OK.

i
Edit Aggregator X
AVG
Source band name: Chla i

Target band name prefix (optional):

| Weight coeffident: ;

L [] Output counts
[[] Output sums

OK Cancel

L
Change Spatial resolution (km/px) to 0.3. Click on RUN.

The Level 3 product appears in the Product Explorer window on the left. Under Bands,
double-click on Chla_mean and the Level 3 image appears on the right side.

Look at the Level 3 image:
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W [evel3

# 03 Metadata

# @ vector Data
&3 Bands

T YXXEN

m.42:1 | 2]

Load the previously created colour scheme file -> select under Range, From Palette, and
look at the coloured image.

Navigation - [7] Chl_a... | Colour Manipulati... X | Uncertainty Visualisa... Worl

Editor: (O) Basic () Sliders (@) Table

Find out how large was the area with Chl a above 46.6 pg/L in the entire lake Peipsi? (mask Chl a
>= 46.6). This is the bloom threshold for L. Pihkva — are higher values present also in other lake
parts?

Optional exercise:

Calculate the average Chl a concentration image for L. Peipsi, using SNAP Level 3 binning of
three images from July (12, 13t™, 14™) 2023. For that, process 2 additional dates with L2
processing according to the scheme from exercise 1. Under Good-pixel expression, type in:
NOT quality_flags_bright and NOT quality_flags_invalid.
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Processing Service

Input File Set

Show predefined file sets

(J Show my outputs ' and of other users

Sentinel 3 OLCI EFR Level 1 ~| Name: Sentinel 3 OLCI EFR Level 1
Sentinel 3 OLCI LFR Type: $3_OLCI_L1B_EFR
SRl e StartDate:  2016-04-26

Sentinel 3 SLSTR RBT Level 1
Sentinel 3 SLSTR LST
Sentinel 3 SLSTR WST

End Date: 2024-12-31
Region name: Baltic

ENVISAT MERIS FSG L1B (Examples) Geo Inventory: Yes
ENVISAT MERIS RR L1B (Examples) v
Show Help
Temporal Filter Spatial Filter
O No filter O No filter (global) @ By region
@® By date range * [ EstHUB ‘ ) / ..""_ . - |
Start > - Map Satellite St Petersbu T 7
date: | 2023-07-12 | (O training ] CankT-Tetep
Tallinn Ty
v
End  [2023-07-14 \ user °
O By date list region_2 ~ic Sea
2017-06-01
2017-06-02
2017-06-03
V2
3 days i
Show Help Go g|e| ithiiania Keyboard shortcuts | Map Data | Terms |

Add and manage user regions

In SNAP, use L3 Binning and select 3 products from July, give new name, save them as
NETCDF4 in your specified directory.

Binning
File Help

I/O Parameters Filter Configuration

Source Products

[3]1L2_of S3A_OL_1_EFR____ 20230714T074031_20230714T074331_20230715T082513_0179_10 1_092_1j 4
[5]L2_of S3A_OL_1 EFR___ 20230712T083253_20230712T083553_20230713T091837_0179_101_064 19
[6] L2 of S3A_OL_1 EFR___ 20230713T080642_20230713T080942_20230714T085100_0179_101_078_19 =

Binning window Filtering can be done according to coordinates - Filter > mark Specify
region or according to the entire input file.
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B Binning X
File Help
1/O Parameters Filter Configuration

Spatial Filter / Region
(® Compute the geographical region according to extents of input products

(O) Use the whole globe as region
(O Enter WKT:
—
v
() Specify region:
t 5 [rad
Temporal Filter

Time filter method: NONE

In this case, Filter > mark Specify region and add coordinates (North 59.271, West 26.085

South 57.721, East 28.31); under Configuration, select +, then AVG from the list and select a
source band MCI. Change Satial resolution to 0.3 km/px. And click RUN.

Target product - A combined L3 product will be generated. Open it, and calculate Chl a using
Band Math (Raster->BandMaths) (MCI_mean*10.9+15.3).

Assign a colour palette and look at retrieved average Chl a values: in which lake part were

the lowest values in July? Were the Chl a values higher or lower in July compared to
September in 2023?

3. Using Level 3 processing in ESTHub for retrieving an average value over a time
period — a basis for the bloom area calculation

This exercise teaches to create average images over the time period in ESTHUb.

14-day composite images are the basis for bloom estimation (Figure 3).
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SENTINEL 3/OLCI FR L1

2016-2022

l ESTHub

Maximal Chlorophyll Index
(Gower et al., 2008)
MCI = Lypg = Lggy — 0.389%(L;53 -

Les1)

Flags:
*sunglint
*bright pixels

‘ Bloom
parameters:
- = duration,
maximal areal
coverage

Figure 3. Processing scheme for bloom detection.

In ESTHub, select L3 processing and Sentinel 3 OLCI EFR Level 1. Then select the Temporal
Filter and By date range insert 14 days, e.g., 24.07 - 06.08.23. Choose the Spatial filter user-
defined region 1, which contains Lake Peipsi.

Temporal Filter Spatial Filter

No filter O No filter (global) @ By region
, s
@® By date range » [0 EstHUB i t;\ | ]
Ma Satellite o
Stat  [2023-07-24 | O taining d P - el
v
End  [202308-06 ] user [ P
(U By date list — St Petersbhurg’
region_2 ° " CaHKT-MeTepbypi
L Stockholm ' =
2017-06-02 °© m ;
2017-06-03 : Balticsea  Egtoni
Latvia! - Moscow-
14 days TN L e W:MQ%xhg_'
Show Help 4Go gle _I&hua%a Map data ©2024 Google | Terms

Add and manage user regions

Then, select from Level-2 Processor Maximal Chlorophyll Index (MCI) from the list of
processors.

From Level-3 Parameters, click on Add, type MCI on the Variable Name.

Level-3 Parameters

Variable Name Expression

e B ]

Please define either variables by a band arithmetic expression or declare band names that already exist in the product. These variables can be used in the aggregator definitions below.

n remeve
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Aggregator AVG, then click Edit — aggregator parameters, put varName = MCl, targetName
MCI_ave; others may be left unchanged. Then click OK.

Edit '"AVG' aggregator parameters

varMName: |MCI | The source band used for aggregation.

targetName: |MCI ave | The name prefix for the resulting bands. If
= empty, the source band name is used.

weightCoeff: | 0 The number of spatial observations to the

power of this value will define the value for
weighting the sums. Zero means observation
count weighting is disabled.

outputCounts: (I If true, the result will include the count of all
valid values
outputSums: (I If true, the result will include the sum of all
| values.

An aggregator that computes an average.

||

OK, and under Aggregator, the parameter info appears:

o

Level-3 Parameters

Variable Name Expression
Ml | = |

Please define either variables by a band arithmetic expression or declare band names that already exist in the product. These variables can be used in the aggregator definitions below:.

m Remove

Aggregator Parameters

AVG v Edit varName=MCI; targetName=MCIl_ave

m Remove

The selected parameters are visible under the Parameters section. Under Good-pixel
expression, type in: NOT quality_flags_bright and NOT quality_flags_invalid.

Change the stepping period to 1 day and the compositing period to 14 days. Choose Binning
as a technique for compositing, and choose the spatial resolution 0.3 (as the pixel for
Sentinel 3 is 300x300 m).

Aggregator Parameters

m varName=MCI; targetName=MCI_av
m

Good-pixel expression |NOT quality_flags_bright and NOT quality_flags_invalid

Stepping period [T ] days compositing:
Compositing period:  [14 | days Spatialresolution:  [03 | Kkmi/pixel
Number of periods: |0 Supersampling: ] pixels
Target width: 1,406 pixels
Target height: 702 pixels
Show Help



Output parameters: Choose a name for the produced file, change the format to NetCDF4,
allow the percentage of failing products (20) and order the production.

Output Parameters

Production name: ‘240706082023 _pe [

Provide a name for the production to identify it later on. If left empty, a name will be generated from the given parameters

O Process to Cluster-Internal-Format
@ User product

Product file format: | NetCDF4 v
Note that the available product file formats may depend on the selected processor
Perform staging step after successful production

Percentage of allowed failing prcducts:‘ 20

Request queue

If you are entitled for seve

select the queue for the project you are processing for

Show Help

Check Request Save Request Order Production

The processing is visible from Productions (in the left pane in EstHub). Download the
generated .nc file, unpack it and open it in SNAP.

Open an image of MCl_ave_mean. Click on the Bands->double-click on MCl_ave_mean ->
Image Window opens. Use the Raster -> Band Maths and calculate Chl a from the band
MCI_ave_mean, using Alikas et al. (2010) formula: MCl_ave_mean*10.9+15.3. Use the
Colour Manipulation Scheme to illustrate Chl a - take the suitable palette (e.g. the one you

,
have previously saved) from . As a result (if you use the following colour scheme), you
will get the following image:

Navigation - [12] chl a | Colour Manipulation -... X | Ung

Editor: (C)Basic () Sliders (@) Table

Colour Value

Add the mask with bloom criteria (both, the shapefiles and Chl a threshold masks need to
be created again) — how large is the area over the threshold in three lake parts?
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Optional exercise. Calculate the average image for the May-October period 2023 and
compare it to the average image of the vegetation period 2022.

This calculation can be done using L3 Processing in ESTHub, first for 2022 and the second
time for 2023. The time period for the processing is 01.05-30.10 during both runs; the
stepping period is 14, and the compositing period is 184. Use the files L3_2023-05-
01_2023-10-30.nc and L3_2022-05-01_2023-10-30.nc for comparison.

Aggregator Parameters

AVG hd varName=MCI; targetName=MCI_av

Good-pixel expression: ‘ NOT quality_flags_bright and NOT quality_flags_invalid

Stepping period: [14 ] days Compositing: | BINNING v|
Compositing period:  [184 | days Spatial resolution: [03 | km/pixel
Number of periods: 1 Supersampling: |1—| pixels
Target width: 1,406 pixels
Target height: 702 pixels
Show Help

Which year had a larger average bloom area? How big % of the lake was, on average,
affected by the blooms?

Additional reading

Ibelings, B. W., R. Kurmayer, S. M. F. O. Azevedo, S. A. Wood, I. Chorus & M. Welker, 2021.
Understanding the occurrence of cyanobacteria and cyanotoxins. In. I. Chorus & M. Welker (eds)
Toxic Cyanobacteria in Water. A guide to their public health consequences, monitoring and
management. Second edition. World Health Organization, pgs. 213-294.
https://www.who.int/publications/m/item/toxic-cyanobacteria-in-water---second-edition, accessed 11
September, 2023.
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